FANDOM


This page has been suggested to be merged with another article, Minimum System Requirements.

If you think this subject deserves its own page, please explain why at Category talk:Candidates for merging or try to expand the page and remove the {{merge}} tag.

Remember to move what links here to the merged page before deleting this one. The page history will remain at this page.

The machine requirements for running ROBLOX can be found on the ROBLOX support site.

Current support

ROBLOX currently supports:

  • Microsoft Windows
  • Mac OS X on Lion and above
  • Android
  • Apple iOS
  • Amazon Fire OS

Linux is not supported yet, but there are ways to get ROBLOX to work on Linux. See ROBLOX on Linux for more information.

See also

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.