Wikia

ROBLOX Wikia

Roblox Studio

Talk0
3,494pages on
this wiki

(Note: This was made about 2011-2012, New one will be made)

ROBLOX Studio is a program that allows users both free and paid to edit their places with a full suite of tools and script editing tools (superior to the Play Solo gear,) and allows them to be saved to the player's local machine, rather than only ROBLOX's server.

ROBLOX would not be what it is today without the ROBLOX Studio. Every single tool in the studio is extremely versatile and can be applied to many purposes. Players must learn to use every single tool in the studio in order to create a successful place.
  • The ROBLOX Studio Interface
  • An example of a place created by a ROBLOXian
  • The Hierarchy System for ROBLOX Studio
  • ROBLOX Studio in 2005
  • Roblox Studio as of 2014

Using ROBLOX Studio

Note: This tutorial is not for the faint of mind! Prepare to read a lot!

Getting Started

ROBLOX Studio is located in the same directory you installed your standard ROBLOX program in. For this guide, you should have it open.

The Main Toolbar

In order to use a program, you must first learn to use the toolbars - ROBLOX Studio is no different. Main toolbars are toolbars that cannot be removed from the view of the ROBLOX Studio program. These toolbars do not contain any icons for buttons. The toolbar lists key shortcuts, if you ever forget any.

File

  • New Place - opens a new place
  • Open Place - opens an existing place on your computer. Browse to your place, click on it, then click
    RBXM

    ROBLOX saves models in the .rbxm format.

    "Open".
  • Close Place - closes the current open place.
  • Save - saves the current open place. If the place does not have a definite location on your computer, it will request for a location.
  • Save As - saves the current open place, but will always request for a location.
  • Publish to ROBLOX.. - After clicking this, choose a place to update. Your place on the ROBLOX site will then be identical to the area in your workspace.
  • Save Selection as model.. - Allows you to save the currently selected block(s) onto your computer. Requests for location.
  • Publish Selection as model - Allows you to publish the currently selected blocks as a free model on the ROBLOX website, or replace an existing model with your selection.
  • Print - prints what is displayed on your screen at a printer of your choice.
  • Print Preview - previews what is displayed on your screen.
  • Print Setup.. - Adjust the settings for your printing from ROBLOX.
  • Recently accessed places: Links to open your recently opened places.
  • Exit: Exits ROBLOX.

Edit:

Selectall

Pressing Ctrl+A selects all available blocks in the workspace.

  • Undo: Undos the previous action performed
  • Redos: Undos an undo
  • Cut: Removes the selected object and sets it as the object that will be pasted into the workspace by the "paste" button
  • Clone: Sets the selected object as the object that will be pasted into the workspace by the "paste" button
  • Paste: Pastes the cloned/cutted object into the Workspace
  • Clear: Deletes the selected object
  • Select All: Selects all objects in the place
  • Duplicate: Clones the selected object and pastes it at the same time.
Find and Replace (ADVANCED):

In order to use these, you must have a script open.

  • Find (Ctrl+F): Type a word into the box that appears when you click "find". The program will proceed to highlight all words that are identical to your input.
    Find

    The FIND tool will help you find text in a script.

  • Find Next (F3) After the words have been highlighted, use this to browse through each highlighted word
  • Replace (Ctrl+H) Has two input spaces, one for the words to find and one for what to replace that word with.
Scripts (ADVANCED):

In order to use these, you must have a script open.

  • Display line numbers: Toggles whether you see numbers next to each script line.
  • Display Selection/Bookmarking Margin: Toggles the margin next to the numbers that allows you to select specific lines
  • Display Folding Margin: Togges the margin that shows the "hierarchy" for your functions in your script (blue dashes)
  • Add a marker: Adds a marker next to the selected line
  • Find next marker: Finds the next marker, goes in sequence from current position to end of script.
  • Find previous marker: Finds the previous marker, goes in sequence from current position to start of script.
    Toolbar

    The Toolbar's Interface

View

  • Start Page: Opens up a window in your display that shows the ROBLOX Website.
  • Toolbar: (below)
Toolbar:

The toolbar is one of your most valuable assets in the ROBLOX Studio. The toolbar contains everything one needs, from a simple block to a complicated jet airplane. In order to use the toolbar, click the toolbar option, then click on the drop-down menu at the top of the toolbar. You can browse to which category, then which object you would like to select, then click on the object. The object will then appear in the workspace. In addition, clicking "Inventory" will have categories for publicly made models and decals, as well as models that you have made on your own.

Explorer

The explorer is important for dealing with complex hierarchy.

  • Explorer: (below)
Explorer:

The Explorer is one of the most important tools in ROBLOX, especially when your place contains complex Hierarchy and multiple models. Upon opening the Explorer, one will find a toolbar that lists the hierarchy of the place. All objects in the place are usually stored within the Workspace. In order to "expand" an object's hierarchy, simply click on the "plus" icon next to it, and to "retract" an object's hierarchy, click on the "minus" icon next to an expanded object

  • Properties: (below)

Properties:

Opening this menu will allow you to view/edit the properties of the object you have selected, for example, if you select a brick, the menu will display the
Prop

The properties in ROBLOX Studio

color, material, reflectance value, and transparency value of the brick as well as other properties.
  • Output: (below)

Output (scripting:

For those of you scripters, the output menu will be where the results of your "print" commands will show up. If your script contains an error, the output menu will display the location of the error and what the error is.
OUTPUT

The ROBLOX Studio Output

The other options in this menu are for advanced users only and have no use for most ROBLOXian players.

Secondary Toolbars

These toolbars are not part of the main toolbar, but some share the same functions, and all are very important to the making of a place.

Some toolbars may not be available for you. Click "View", "Toolbars", then enable all of the toolbars.

Standard

This toolbar includes buttons that are vital to the making of any place, complicated or simple.

Tip: Clicking on an object selects it.

Standardtoolbarone

New Place, Open Place, Save Place

  • New Place (CTRL+N) - creates a new place and causes your screen to display that place.
  • Open Place (CTRL+O) - allows you to browse to a place on your computer, then open it. To open a place, click this button, browse to the folder your place is in on your computer, click on the place, and click "Open".
  • Save Place (CTRL+S) - allows you to save the place you currently have open.
  • Cut (CTRL+X) - Takes the selected object, removes it, and allows it to be pasted into your workspace infinitely (see below)
  • Copy (CTRL+C) - Takes the selected object and allows it to be pasted
    Standardtoolbartwo

    Cut, Copy, and Paste

    into your workspace infinitely
  • Paste (CTRL+V) - Must have copied or cutted before using - Takes the cutted/copied object and puts it into the workspace when clicked. Can be used infinitely after copying/cutting.
  • Undo (Ctrl+Z) - Undos the action you just performed. The drop-down menu does not serve any purpose
    Standardmenubarfour

    Undo, Redo, Group, Ungroup

    currently.
  • Redo (Ctrl+Y) - Redos the action you just performed. The drop-down menu does not server any purpose currently.
  • Group (Ctrl+G) - Allows you to group the selected objects and lock the grouping so they can all be selected and moved together at need
  • Ungroup (Ctrl+U) - Breaks the connection of a selected group of objects
  • Rotate (Ctrl+R) - Rotates the selected object on a vertical axis
  • Tilt (Ctrl+T) - Rotates an the selected on a horizontal axis
    Standardtoolbarfive

    Rotate, Tilt, Move up, Move down

  • Move up (Ctrl+E) - Moves your studio up wards
  • Move down (Ctrl+Q) - Moves your studio down wards

Edit

This toolbar includes buttons that allow you to manipulate selected, physical objects. All of the following do not have hotkeys.

  • Drag - Clicking, holding, and dragging on a selected object with your mouse with this tool allows you to move the object. Clicking and holding on a selected o
    Editbarone

    Drag, Move, Resize

    eject and pressing R rotates the object, and pressing T tilts the object.
  • Move - Applies a set of intangible handles to the selected object. Each handle can be dragged to move the object with extra precision. Each handle only controls one axis of the object.
    Editbarthree

    Paint Bucket and Color Select

  • Resize - Applies a set of intangible handles to the selected object. Each handle can be dragged to resize the object with extra precision. Each handle only controls one axis of the object.
  • Lock - Disallows an object from being selected until the object is clicked again with the lock tool.
    Editbartwo

    Lock and Anchor

  • Anchor - Disallows an object from being moved by an environmental force (The person editing the place is not an environmental force)
  • Collision Check - Automaticly UnHighLight it, and it Auto Cframes
  • Paint Bucket - Select a color in the drop down menu, then click on a block to paint it that color!
    Editbarthree

    Paint Bucket and Color Select

  • Color Select - Click on a block to select its color for your paint bucket!
  • Editbarfour

    Material Tool

    Material Tool - Select a material in the drop down menu, then click on a block to make the block that material!
    Editbarfive

    Smooth, Glue, Weld

Surface Tools

This is actually part of the Edit toolbar, but this part of the toolbar is so big it deserves its own sub-category.

  • Smooth - Applies the "smooth" surface to a facet of a block. The smooth surface does not secure a block to another block.
  • Glue - Applies the "glue" surface to a facet of a block. The glue surface joins a block to another but will break after a certain amount of stress is applied by a character or explosion unless anchored.
  • Weld - Applies the "weld" surface to a facet of a block. The weld surface joins a block to another and can only be broken by explosions unless anchored.
  • Editbarsix

    Stud, Inlet, Universal

    Stud - Applies the "stud" surface to a facet of a block. The stud surface only joins to inlet surfaces. Joints can only be broken by explosions unless anchored.
  • Inlet - Applies the "inlet" surface to a facet of a block. The inlet surface only joins to stud surfaces. Joints can only be broken by explosions unless anchored.
  • Universal - Applies the "universal" surface to a facet of a block. The universal surface joins to both studs and inlets alike. Joints can only be broken by explosions unless anchored.
  • Hinge - Applies the "hinge" surface to a facet of a block. Anything on a hinge surface, except for glued or welded blocks, can rotate freely on the hinge until the joints are broken. Joints can only be broken by explosions unless anchored.
    Editbarseven

    Hinge and Motor

  • Motor - Applies the "motor" surface to a facet of a block. Anything on a motor surface, except for glued or welded blocks, will constantly rotate on the motor until the joints are broken. Joints can only be broken by explosions unless anchored.

Auto-Join Tools

These tools don't actually automatically join blocks (as implied by the name) but they still are very nifty when it comes to modeling in smaller dimensions.

  • Move - Same as the drag tool, but with a grid measure.
    Specialbarone

    Move, Rotate, Resize (special)

  • Rotate - Creates three handles on the selected part. Moving the handle will tilt the part on a certain axis.
  • Resize - Creates three handles on the selected part. Moving the handle will resize the part on a grid measure.
  • Grid 1 - Causes bricks to be manipulated by the aforementioned tools on a standard grid measure.
  • Grid .5 - Causes bricks to be manipulated by the aforementioned tools on a grid measure half the size of
    Specialbartwo

    Grid Sizes

    standard.
  • Grid x - Causes bricks to be manipulated by the aforementioned tools freely without a grid measure.
  • Manual Joints - an option, where, when a block is put next to another block by the aformentioned tools, the block is joined to the other block.
    Specialbarthree

    Manual Joints, Toolbox

  • Toolbox - when clicked, a toolbox displaying free ROBLOX-employee made parts is shown. To access more parts, click the drop-down menu. To access player-made parts, click "Inventory" and select "Free Models" from the drop-down menu.

Camera

Most of these are self-explanatory, but some will need explanation.

  • Pan Left - Move your point of view left.
  • Pan Right - Move your point of view right.
    Camerabarone

    Pan Left, Pan Right, Tilt Up

  • Tilt Up
  • Tilt Down
    Camerabartwo

    Tilt Down, Zoom In, Zoom Out

  • Zoom In
  • Zoom Out
  • Look at Object - Looks at selected object
    Camerabarfour

    Look at Object, Zoom Extents

  • Zoom Extents - Zooms all the way up into the selected object

Test

This toolbar contains tools that will allow you to test your place and how it behaves.

  • Play - Sets all blocks in your place into motion!
  • Pause - Pauses all blocks in your place.
    Test

    Play, Pause, Revert

  • Revert - Reverses all blocks in your place back to what they were before you played.

Testing as a Player

Whether you have no scripts, or your entire place is scripted, you will want to test it within in the Studio so that you are able to catch and eliminate existing bugs in your game before you actually release your game to the public, thus heightening players' respect for you. Roblox Studio offers two different modes for testing, 1: Solo mode, 2: Server-Client mode. Here is a breakdown of each:

Solo Testing Mode

In order to access Solo Testing Mode (you must currently have your window on an open place) click Tools > Test > Play Solo {C}Solo Testing mode starts your currently-edited place as if you joined it in Solo mode. Note that most leaderboard scripts (or any script that requires the OnJoined or OnJoining event) will not work, or will break, since that function is not called. (Most likely a bug.)

Server-Client Mode

The Server-Client mode is the best, but slowest way to test your map. It will catch most, if not all Lua errors.

Starting Server-Client Mode
  1. First, click Tools > Test > Start Server.
  2. In order to add players to your server, click Tools > Test > Start Player.
  3. Repeat step 2 as many times as you like.

After this, you will have several windows open. One will be the server, where you still have all the controls and functionality of ROBLOX studio, and the others will be "players" within the server that you can also control.

Publishing

Once you are done editing and testing your place, will you want to upload it to ROBLOX so other users can play it. Go to File -> Publish place to ROBLOX, then follow the steps to get it published. Depending on the size of your place, it may take about 15 - 30 seconds for it to get published. Once it says it's done, allow another minute for ROBLOX to generate the place icon. Your place is now uploaded to ROBLOX for users to play in. Enjoy!

Start a discussion Discussions about Roblox Studio

Around Wikia's network

Random wiki